How do I turn Advanced Bounce Processing off?

How can I turn off Advanced Bounce Processing? I have the config file settings set up as follows:


However, at the end of a bounce processing run the log says:

“phpList - 500 bounces processed by advanced processing” and I see that some of the subscribers have been processed using my regex rules.

@mtasmithjk i suspect that you need to explicitly set that define to 0 and remove the ‘#’ character as advanced processing might now be the default.

Ensure that you have only one such statement in your config file, as only the first will be used.

Thanks @duncanc, I will give that a try. Do we need to reboot the phpList server for the change to take effect?

There is not much documentation about how phpList manages bounces without Advanced Processing turned on or how it manages bounces that don’t match a regex rule if Advanced Processing is turned on. Can you point me to where that information might be in the documentation?


Changes to the config file apply straightaway.

There is the online docs on, or the old docs which are probably mostly accurate.

If a bounce does not match any rule then nothing else happens to it.

The config file change did not appear to work. Customers were blacklisted using the bounce rules. Only one statement in the config file.

I read the online docs and I don’t think it documents that nothing happens if it doesn’t match a bounce rule. That is good to know. So if we are successful (eventually) in turning off advanced processing, then the bounces will be added to the list of bounces that now appear in the “View Bounces”? This would mean that all bounces have to be managed manually, correct?

@mtasmithjk It sounds like advanced processing is always on, so you will need to disable (not delete) your bounce rules.

If you disable the rules then all bounces will go through the “consecutive bounces” processing, but anything above that will have to be done manually.