Fromfield functionality doesn't work as expected?

I migrated last week from phplist 2.10.5 to 3.0.12

I have always used syntax MyName in the fromfield

I’m now sending out a test email (with the new version) and in Gmail I now notice that when I hit the reply button, not is the return address, instead the address the email was set TO is the return address !??

Is this known ?
Something I’m missing ?

I notice that my SPF records are not correct (server migration end last week)
I wonder if that has anything to do with it ?
Investigating further.


No, SPF is not the issue either.
This is a very repeatable problem with Gmail.

What am I missing ?
I’m basically using the third method suggested when you click the info button next to the fromfield

No one else has noticed this with gmail ?
Is it just me, my setup, my phplist installation, gmail itself ?


When I check the headers, one of the headers says:

From: Peter

Frankly I would expect it to work then ?


Oh wait … there is no Reply-to header ??
I assume this is the problem ?

Any insights ?

I’d suggest that you use:

> Name <>

as the format of your ‘From:’ address.

Did you setup your bounce email address too? (envelope from) setting in the config.php file


Yes, the bounce address is

That works well !
Bounces are being processed via a cron job

PS. phplist ads <> OK !
I should have written:

I have been doing some more tests and I think I understand the issue now. So this post to explain and close the issue.

I ‘hacked’ the code and added a Reply-to header to test (I used inspiration from: )

The result was absolutely the same, so no noticeable improvement.

Then it occurred to me, that my Gmail is setup with the same email address as the From address in my phplist sent emails. And the test emails I have been sending out were sent to different addresses, but still my addresses retrieved by my Gmail client (it checks the pop email inboxes).

For instance, Gmail knows I use
and phplist fromfield is set to: Peter
and the test email was sent to: (which Gmail checks by emptying the inbox)

It’s standard behaviour in Gmail, when you reply to your own older reply (to another email), that gmail still uses the original sender email address. And I figured this could be a similar situation. Gmail sees the email is from ‘me’ ( and then assumes it is a reply to an older email from somebody else (, and hence uses that email address ( to send the email to.

I was able to confirm that by sending a test email to another gmail account that is not linked to my address.
There the functionality worked like I assumed it should work. was used as reply address.
PS. I reverted the ‘reply-to’ hack first before I tested. So purely with the ‘from’ field, it worked as expected.

This issue can be closed.

Thanks for the update, the explanation will most likely help someone else in the future!

1 Like