Error: The pageroot in your config does not match the current locationCheck your config file

Brand new installation (downloaded source yesterday, version 3.4.1). Installed in . Created the DB, set DB credentials in config OK.

Initial startup (before creating database) shows this error:

The pageroot in your config does not match the current locationCheck your config file.

I looked in the config file, and there is no ‘define’ for $pageroot. (or any reference to anything ‘pageroot’ ).

It appears that the standard installation requires the software to be in the ‘lists’ folder. But there is no mention in the install docs of any change to make to the config file to adjust for a different location of the software.

In my case, the software is installed in , so I had to add this to the config file:

$pageroot = '/maillist';

Suggest a fix to the documentation.


1 Like

The info you refer to is actually held in the config_extended file which has all the options you should ever need.

// if you change the path to the phpList system, make the change here as well
// path should be relative to the root directory of your webserver (document root)
// Warning: Do not change this after installation. You can only change this before you
// install and initialise phpList.
$pageroot = '/lists';

Yes, I saw that (the extended config file) before I posted this question. And I fixed the problem. (I also searched the forum, which did not have a clear answer to the error, although I did find an old bug report mentioning the issue, but not the resolution.)

My question relates to the fact that that setting is not mentioned in the installation documents ( ).

1 Like

@RickH Good idea. The source for that manual page is here and easy to edit: (the manual was migrated to use Bookstack, and now anyone can register and edit pages in the browser)