Details of Subscribers

Is is possible to show the first and/or last name of subscriber in addition to OR instead of the email address

TIA

The Subscribers plugin displays a page on which you can see any subscriber attribute in addition to the email address.

You can see the available plugins by clicking the ‘Find plugins’ link on the plugins page, menu Config > Manage plugins.

I cannot see a ‘Find plugins’ link on that page.
I do see a message ‘The plugin root directory is not writable, please install plugins manually’

Forgot my last email…just seen the resources link at the bottom of the page

You should correct this first. It is much simpler to install plugins automatically.

This may be because there is no plugin directory in the Lists folder, I will contact my friendly ISP who set this up for me,

Thanks

[quote=“dogluvver, post:6, topic:645”]
This may be because there is no plugin directory in the Lists folder,
[/quote]It’s actually in lists/admin directory. :wink:

Oh, so it is - thx,

Any ideas why I would get that error message?

(Can you tell I am not a computer geek?)

Which config file are you using? The quick start config/config.php or the full config/config_extended.php (renamed to replace the config.php file)?

In your config file, what path are you using for your plugin directory?

define("PLUGIN_ROOTDIR","/home/me/phplistplugins");

OR

define("PLUGIN_ROOTDIR","plugins");

Also, what is your path to the plugins directory? EG: …admin/plugins or what?

What permissions does your plugins directory use? (Should be 755).

Please let us know the info above which should help us help you.

This is way beyond my pay grade :smile:

I am using the /home/me/phplisplugins path.

I cannot see a path to the plugins directory nor do I know the permissions.

I will go back to my friendly ISP for that information - you may consider this thread closed, I thank you for your assistance and for the promptness of the replies.

In this case, simply change (or add) the following line to your config/config.php file, using a TEXT editor such as NotePad.

define("PLUGIN_ROOTDIR","plugins");

If you see the line:

define("PLUGIN_ROOTDIR","/home/me/phplistplugins");

simple prefix the line with a Hash “#” so it looks like this:

#define("PLUGIN_ROOTDIR","/home/me/phplistplugins");

Simply, this will allow you to use the correct plugins directory and you should then see the Find Plugins link.

I had the same issue after install. Only managed to solve it by:

  1. Copying

    define(“PLUGIN_ROOTDIR”,“plugins”);

    from config_extended.php to config.php file.

  2. Setting plugins permission to 777

$ sudo chmod 777 /var/www/public_html/lists/admin/plugins

NO! Change them to a max of 755 immediately! 777 allows ANYONE potential access to your server files!

Files should have permissions of no higher than 644 and directories a max of 755.

Thanks!

But not sure why 755 wouldn’t work for me. The message will appear again:

“The plugin root directory is not writable, please install plugins manually”

It only works with 777. Did I miss something?

@ultratux It looks like neither the owner nor group include the web server process. Check what they actually are.

Sorry, if the group does include the web server process then the permissions need to be 775.