back to phpList.org

Config bounce set up


#1

I have set up a cron job for bounces and I am receiving bounce messages to my email address at bounces@myserver.com

However, I am not getting any notifications in PhpList. I went into config and saw the following so I am a bit confused:

// when the protocol is pop, specify these three
$bounce_mailbox_host = ‘localhost’;
$bounce_mailbox_user = ‘* removed ';
$bounce_mailbox_password = ’
removed *’;


#2

@DanOShea phpList needs to be able to monitor the bounces mailbox to read the mail. See: https://www.phplist.org/manual/ch040_bounce-management.xhtml


#3

I replaced the following with:
$bounce_mailbox_host = ‘localhost’;
$bounce_mailbox_user = ‘* removed ';
$bounce_mailbox_password = ’
removed *’;

$bounce_mailbox_host = ‘mail.digdevdirect-us.com’;
$bounce_mailbox_user = ‘danoshea@digdevdirect-us.com’;
$bounce_mailbox_password = ’password123’;
(Not exact password)

But it appears PhpList is still not pulling the data from the server.


#4

Thanks, you pointed me in the right direction. I’ll put this down in process of elimination bullet points for others:

  1. Create email address in Cpanel specifically for bounces. (Which I did - bounces@digdevedirect-us.com)
  2. I was getting the bounces in my email client, but none in PhpList. So I had to do some testing as to why. I corrected the email credentials to the following in the PhpList config file -
    $bounce_mailbox_host = ‘mail.digdevdirect-us.com’;
    $bounce_mailbox_user = ‘danoshea@digdevdirect-us.com’;
    $bounce_mailbox_password = ’password123’;
  3. I had turned off the setting for manually processing bounces as I had set up a Cron job. So I reset it to “1” temporarily so the “Process Bounce” tab would show in “Manage Bounces” in PhpList.
    // set this to 0, if you set up a cron to download bounces regularly by using the
    // commandline option. If this is 0, users cannot run the page from the web
    // frontend. Read README.commandline to find out how to set it up on the
    // commandline
    define(‘MANUALLY_PROCESS_BOUNCES’, 1);
  4. Finally, out of the three pop options, my server only accepted the strict SSL, as I needed to use Port 995.
    // the “port” is the remote port of the connection to retrieve the emails
    // the default should be fine but if it doesn’t work, you can try the second
    // one. To do that, add a # before the first line and take off the one before the
    // second line
    // $bounce_mailbox_port = ‘110/pop3/notls’;
    // $bounce_mailbox_port = “110/pop3”;

// it’s getting more common to have secure connections, in which case you probably want to use
$bounce_mailbox_port = “995/pop3/ssl/novalidate-cert”;

Once I had the connection, the bounces immediately came through.

I went and reset my Cron by setting ‘1’ back to ‘0’ removing the manual processing of bounces.


#5

@DanOShea Happy to hear it’s working now. Thanks so much for sharing your solution with the rest of us!