Campaign processing timing out

Hello, I am new to Phplist so I am probably missing something very obvious, but processing my campaigns only seems to work in batches of 1 minute.
For example trying to send 17 messages with a throttle of 12 secs each (ie. 5per min) takes 4 resumes to complete the job. Changing the throttle size changes the number of emails that go out in one minute before it stops processing.
I have tried setting various batch sizes and have even tried auto throttling, but the result is always the same 1 minute processing time…

this example is 3rd process report of a campaign with batch and throttle of 0/16200/12
Sending in batches of 10000 messages
This batch will be 9990 emails, because in the last 16200 seconds 10 emails were sent
Processing has started,
One campaign to process.
Looking for subscribers
Found them: 7 to process
Size of HTML email: 21Kb
Processed 6 out of 7 subscribers (remember 10 processed in earlier process)
Script stage: 5
5 messages sent in 61.04 seconds (294 msgs/hr) (still leaves 2 more to process)

A related question. If I leave the browser window open, shouldn’t I see an ongoing status report on the screen? All I see is the spinning “p” and stop button.

Hope someone can help me,

To send a maximum of 5 messages per minute manually, your config/config.php file should include the following settings:


# batch processing
# if you are on a shared host, it will probably be appreciated if you don't send
# out loads of emails in one go. To do this, you can configure batch processing.
# Please note, the following two values can be overridden by your ISP by using
# a server wide configuration. So if you notice these values to be different
# in reality, that may be the case

# max messages to process
# if there are multiple messages in the queue, set a maximum to work on

# define the amount of emails you want to send per period. If 0, batch processing
# is disabled and messages are sent out as fast as possible

# define the length of one batch processing period, in seconds (3600 is an hour)

# to avoid overloading the server that sends your email, you can add a little delay
# between messages that will spread the load of sending
# you will need to find a good value for your own server
# value is in seconds, and you can use fractions, eg "0.5" is half a second


You don’t mention your current settings, so I assume you haven’t set them?

Thanks for the feedback Dragonrider.
I had not included the config for manually_process_queue, I thought that was only for commandline usage, .
I also missed max_process_message. (I think that may well be the cause), though I don’t understand the difference between max_process_message and batch_size.
I will try a few more tests adding those parameters…

I apologize, sorry I wasn’t clear enough in the initial request.
As for batch_size I have tried ranges from 0 to 2500
as for batch_period I have always used a value over 100000 (my host has very tight restrictions)
and throttle varied from 5 to 20 (or used auto-throttle)
Regardless of settings, the number sent in 1 minute is a factor of the throttle, but it never sends more than those per process… eg throttle:12 = 5 sent. : throttle:6 = 10 sent.

Slightly off track, I’ll just add a comment.
Perhaps its my complete lack of understanding of the application, and why I am having so much difficulty.
Although it will never apply to me (at 1 campaign 4 times per year to 2000 subscribers) I find the above parameters seem to relate more to individual campaigns than to application configurable data. Just seems odd to me to set variable data at that juncture. .Just my 2 cents worth.

Finally overcame the throttle problem. I never succeeded in using the on screen process, but once I managed to get a working API key I was able to submit and process a campaign using the remote process server.

1 Like

Good job :smile:

Keep us posted on how it works :slight_smile: Did you use the remote queue processing or your own one?

Hi Anna,
Sure, here is my experience. Forgive me for being a bit long-winded but hopefully the excess information is of use.
To recap, I had a group of 17 poor long-suffering users who were willing to give me feedback on each test that I ran.
While I was testing the on screen queue submission it basically defaulted to processing as many users in 1 minute that I had controlled by throttling. It would process that minute, then stop, It would not continue on its own until I pressed the continue button, again and again.

I setup the remote processing with auto-throttle on and tried a couple of test runs and was able to establish, with my users help, that regardless of what I set, it always processed 2 or 3 messages in a minute and then would pause for anywhere between 5 to 10 minutes before processing the next group. The process time for the complete job of 17 messages was between 30-35 minutes each time.

Time was running out, so I had to submit my campaign of 2100 subscribers and used the following settings (chosen more at random than anything):
#define(‘MAILQUEUE_THROTTLE’,3); (see note below)

I still don’t know how it computed how much to throttle and process the full queue.
i.e. how many in a batch?, was it still working in only 1 minute spurts?, was throttling being done on batches or messages or both? etc.
I was concerned that I would exceed my hoster’s limits. (it did, but I seem to have got away with it).
The full job took 12.5 hours to process (twice as fast as my host’s limits).
Anyway, I am finished now. Next mailing won’t be for another 3 months. Phew!

Point: the config file at one time had mailqueue_throttle set, but on final run it was commented out. Can I be sure it was not using it, or was it using the previous setting still in cache or database?
All my problems stem from confusion of what and where are ‘messages’ and ‘batches’ being used interchangeably with throttle commands.
Other than that, I am very pleased with the software and would recommend it to anyone.

Hope the above helps someone, and even more, that someone can advise what I was doing wrong to get it to work.

I am glad you like phpList :slight_smile: There are some suggested ways to share the phpList love here:

Sorry I am not much help with the rest though, I have always used myself (and I work for them now) because I don’t really have the time of will-power to selfhost. I don’t have to deal with any of this batch and throttle stuff there, it’s all nice and automated :smiley: *Anna likes a quiet life"