back to phpList.org

Blank admin: "Invisible home" body class

Hi!

I can’t solve this. All I got when I log in is a blank page. The code produces some HTML, though, but it’s not visible, because of (I guess) this “invisible home” class applied to the body tag. I don’t know why this is happening. I updated to the last version (3.4.1) and still no luck.

What should I do? Thanks!!

I do a dump of database and put in another phplist installation (local), The problem was solved, then I put the dump to a new database in phplsit production.

I don’t know why, but I think the problem can back any moment.

This is most likely related to recent jQuery upgrades. The invisible body class should be removed by jQuery when it loads. You can use browser debugging tools to see if jQuery scripts are failing to load with 404.

1 Like

Thanks, I’ll tinker with that, see what happens. I wonder, why there’s no non-javascript fallback? I think it would be reasonable to avoid things like this…

Hmmm, this is as far as I can go. I deleted both the “invisible body” and “hidden” classes from the body and the div (below the “page title” h4) tags respectively. This should be the campaigns page, but still it’s not loading useful content. I think the problem lays underneath… Any hints?

Hi,

I am also facing same issue. After installation it worked for 5 days & today suddenly Admin page is blank.

If i go to view source, the last line is as below. I think the page is not loading fully.

title=“Close this box”>Hide</a><p>phpList will work without Javascript, but it will be easier to use if you switch it on.</p></div></noscript>

1 Like

Hi, can you please enable php error reporting on your server an check any errors on the logs? You can check how to do that here.

Same here. Just after upgrading from 3.3.4 to 3.4.1, I can see the login page, then once logging in it gives the blank tag. No errors in the apache error log but access log shows 500 response code. But I do see the same stuff with view source.

and the page doesn’t fully load. via browser or phplist command line, it ends here:

<!-- content starts here -->
<h4 class=“pagetitle”>Dashboard</h4><div class=“hidden”><a href="./?page=home&amp;tk=56ecbc861a5434117444f1e4de848504" title=“Go to the dashboard page”>Dashboard</a></div><noscript><div class=“note d533fc9acf638d1”><a href="./?page=home&amp;action=hidenote&amp;note=d533fc9acf638d1" class=“hide ajaxable” title=“Close this box”>Hide</a><p>phpList will work without Javascript, but it will be easier to use if you switch it on.</p></div></noscript>

and then that’s it. Doesn’t ever finish the html

version 3.3.9 works fine. Maybe it’s a php issue and have to upgrade php to v7 before using 3.4??

I’m on php 7.2, just updated the server. Still blank. :man_shrugging:

@allvoxman Do you also see a 500 error in the access logs?

Perhaps this is related to the update check, and / or a strict Apache security policy or PHP extension.