back to phpList.org

Autoresponder blank page


#1

Manual Installed Autoresponder and common plugin on PHP list 3.3.1.

Obtained the plugins from this page:

everything was working up until this install. Now I only get a blank page.

Help please

Oh, during manual install I was asked if I wanted to overwrite files for the common plugin and I said yes.

Centos 6.9 with another same version of phplist running on another domain on the same server without these installs runs fine.


#2

@pancakehollow You will need to remove the plugin from the plugins directory. Remove the file Autoresponder.php and the directory Autoresponder.


#3

I did manage to recover the system through a backup, but I’d like to get this to work. I re-installed the common plugin update and everything works when I install that, yet once I install (manually or automatically) the Autorepsonder plugin, I return to a blank page.


#4

@pancakehollow Look in the web server log file or the php error file for any errors. What release of php is being used?


#5

PHP Version 5.5.38

It’s strange that I get a blank page only when activating the autoresponder. You have a few very attractive plugins that I would like to take advantage of.

Thank you.


#6

@pancakehollow Have you installed other plugins, do they work or fail in the same way as Autoresponder?

Also, are you sure that you have the latest version of the Common Plugin and Autoresponder Plugin from GitHub? What is the reason for installing manually, instead of through phplist?


#7

I am having the same issue, when Autoresponder is installed the entire site returns a 500 error.

I have tried every suggestion I have found in this, and other forums…including the absurd idea that changing the database password would fix it (it doesn’t). The config.php is the same as it’s always been, permissions are correct, Common is the latest, ALL stated prerequisites/dependencies are satisfied:

Ubuntu 14.04.5 LTS
PHP 5.6.36
phpList 3.3.3
Common plugin 3.7.18+20180528
Autoresponder plugin dated 2018-02-11 (it won’t load so I can’t get the exact version number)

What other information can I provide to help solve this?

I even reduced Autoresponder.php to just the four “use” lines and the declaration portion of the class (even removed the __construct() function) and it still throws a 500 error, so I can’t even point to specific function.

Any suggestions?


#8

@jeffsaunders what is the background to this? Did it use to work but now doesn’t?
If this is a new installation then how have you managed to install an old release of the plugin?

Also, are you sure that you are using php 5.6 and not an earlier version?


#9

We upgraded from 3.3.1 to 3.3.3 (all works fine) then we decided to add Autoresponder. I have installed the plugin both from https://github.com/bramley/phplist-plugin-autoresponder/archive/master.zip via the “Plugin package URL” from the phpList “Manage Plugins” page and by downloading it directly from GitHub and manually copying the files. Both methods result in the same 500 error.

Here’s my PHP version:

root@ubuntu:/var/www/html/paths/web/lists/admin/plugins# php -v
PHP 5.6.36-1+ubuntu14.04.1+deb.sury.org+1 (cli)
Copyright © 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies


#10

@jeffsaunders Earlier you referred to a date of 2018-02-11. Where is that from as it is not the current release of the plugin.

The command for the php version is for the command line, possibly the web server uses a different version. You need to run phpinfo, which is under the System menu if you have Common Plugin installed.

500 errors should be reported in the web server logs.


#11

DOH! I ran phpinfo() and Apache was indeed still running 5.5.9…ugh! I have updated all the relevant modules and cleared all conflicts and we are now up on PHP Version 5.6.36-1 in Apache, and Autoresponder is no longer breaking phpList.

Duncan, thanks for your speedy help!!

Important safety tip - make sure the PHP modules for Apache are also upgraded AND there are no conflicts with prior version modules keeping it from running!