back to phpList.org

Attributes Not Loading


#1

I’m running a survey study where I have people that I send a different survey to people once per week. I had a URL attribute and each time I loaded the list it had a new URL.

Today, for some reason the URL attribute wouldn’t override and replace the old URL with the new URL in the list. I deleted the URL attribute in phplist and tried to reload it but it won’t recognize the field. I renamed it in the tab delimited file but it still won’t recognize it.

Please advise.


#2

Check the database to see what the Attribute table is named there. Deleting the old one may have confused things.


#3

I went into the manage attribute menu. Or are you saying to go directly into the database itself?


#4

I meant the database itself. If you have access. The tables are named after the attribute name you gave, with a prefix.


#5

What do you mean by “won’t recognise”? phplist should show the first 50 lines of the import file as a test, does that display as expected?

Which release of phplist are you using, as there was a change in this area in release 3.3.7 to do with the field separator character.


#6

I have 3.3.6.

I loaded up a list of subscribers (i.e., people who agreed to participate in the study). Each email that goes out has a new URL. As I was trying to reload subscribers with a new URL, the database refused to change from the old URL to the new URL. THat is, it refused to overwrite the old data.

So I deleted the old field in the manage attributes menu. Now it won’t even detect there’s a new field. I tried to add it back manually in manage attributes but it still doesn’t work.