2nd phplist instance same domain

In the config file I changed /lists to /specials (new folder name holder the instance). This is all correctly picked up by the subscription settings.

Where else do I need to make changes, as currently the subscribe button does not work.

Thank you for you assistance.

I still have not figured it out. Hope some kind soul can help before the weekend.

What do you mean by this?
You need to check the Settings page, there are a number of URLs that might need changing.

In the subscription settings all URLs include the correct path “/special/”.

What I experience when clicking the subscribe button is a brief flicker of the subscribe page which then reappears.

I activated define(‘VERBOSE’, true); in config.php but the log of events does not report anything.

Thanks Duncan

@Tom1 Try using the browser developer tools to see the http request and response. That might show what is happening.

So what is happening here: No api calls are going out. Are there other places aside from the config file and the subscription settings where the folder name has to be adjusted? Does the fact, that the folder name has a dash (as-special) in it play a role? Thanks

@Tom1 Try looking at the html source for the subscribe page to see whether it looks correct. The Subscribe button should be within a form.
But the developer tools should show you what is happening. The network tab shows the request and response, and the console tab will show any errors.

Unless this is secret, what is the URL you are using?


@Tom1 An error message is being displayed but your styling makes it difficult to notice

Bitte wählen Sie ein Liste aus, bei der Sie sich anmelden wollen

Possibly on the Edit subscribe page in phplist, you have not chosen a list.

It was the check mark, making the list public. Thank you so much duncan!!!